CHORD CHARTS

 

You can create a Chord Chart window by either pressing Cmd-N, by opening a chord chart file, or by pressing the 'Add chord to chart' button on the Keyboard Window. They are saveable documents.
Click on a chord name to hear it. A double click on a chord (or Cmd-E) lets you rename it (but it will sound the same) See under the Edit Menu.
Use the left/right arrow keys to play through the list. Pressing the up or down arrow will silence any sustaining chord. The home/end and page up/page down keys also work as you would expect.
The Return key will also play a selected chord. Shift Return will play it and transfer the chord to the Keyboard window, as if the transfer button were on.
Other keys:

m      Show, hide page margins
t      Show, hide time signature
b      Show, hide bar numbers
 
+ -    Increase, decrease number of bars per line 

       (affects lines containing the first and last selected chord and all in between)
 
p
      Automatically makes repeat marks round selected chords
r
      Refreshes the page if it looks messy for some reason.
       Cmd-r is a 'stronger' version which also resets the default barline spacing
 
space  Blank chord
/      Cycle through strum marks (off, 2 per bar, every beat)
 
Cntrl arrows

       Nudge chord or strum mark position. If shift is also depresed, they will move further.
(NB some operations reset the positions)

Multiple selections work in the usual way: shift-click for contiguous and command-click for non-contiguous selection.
Important Version 2 change: Normally the pasted chords are added to the end, but if there is a single selection they will be inserted just before that chord/beat. So to insert at the very start, select just the first beat of the first bar.

Note that if you have selected parts of bars rather than just whole bars, when pasting the start of a bar will still be preserved, and extra time signatures may be put in before and after the new pasted data to accommodate this. It is logical, but not always what you might expect. It's usually best to select only full bars. Note that you may need to see all the strum marks (hit '/') in order to select the beats you want.

Summary of edit commands in Chord Chart window:

COMMAND     KEY       COPY TO CLIPBOARD?    MUSICAL LENGTH ALTERED?
Cut         Cmd-X        Yes                   Yes                              
Copy        Cmd-C        Yes                   No               
Clear       backspace    No                    Yes              
(Blank)     Spacebar     No                    No
(Paste      Cmd-V         -                    Yes)

Thus every permutation of the last two headings is covered.

Barlines may be dragged left or right to improve spacing. This even includes barlines on the right margin (but not the left).

Text can be inserted anywhere with a click when the text ('T') button is on. A double click on the text allows editing (see above), backspace deletes. Notice that you can select chords OR text but not both at the same time, and no operations can be applied to both at once.

Margins can be changed either by dragging them (first page only) or via the settings dialog. They only relate to the actual staves, not the text items. Note that text positions, unlike chords, are spatially unrelated to the music. This is also true of symbols, except of course the barline, time and key signature symbols.

Transport buttons:

1: Text When pressed, clicks on the chart will allow you to enter text, which can then be altered in size or style, and dragged to any position.

2: Symbol A short click will allow symbols to be inserted. They behave much like text, but the barlines, key signature and time signature symbols can only be entered at barlines (for the first bar in a row, click on the extreme left of the bar). A longer click brings up a pallette from which you can select the symbol you want. You must have the new Version 2 Chord Studio font for the symbols to display properly.

Time Signature (3/4 symbol)
When entering a time signature a dialog opens with two choices:
Affect this bar only: The next bar will automatically have the original signature entered. Beats will be added or deleted from the end of this bar so that the rest of the chart is just as before.
Shift beats in subsequent bars: The new signature will last until the end, or to the next different signature, so again beats are added or deleted from those later bars.
Note these options affect what happens if you just 'Clear existing' too.
You will be warned if beats are about to be deleted. Note that undoing time signature changes restores the signatures but won't bring back any deleted chords.
The Options menu command 'Clear all barline symbols' removes all repeat and double barlines. To remove them individually, insert the normal, single barline.

3, 4: Transpose Transpose selected chord/s up or down. In Version 2, this will not change any user-typed name, just the notes.

5: Transfer When pressed, clicked chord will be sent to the Keyboard Window where the notes are shown and the usual chord name is displayed (disabled if the Keyboard Window isn't open).

6: Play Plays the sequence of chords (or hit Zero). Stop by pressing again (or hit Enter). Play will start from the beginning, unless a single chord is selected, when it will start from that chord. There are two playing modes: normal or special Quicktime.
Normal: Will show progress by selecting the chord being played, but timing may be sloppy (for example, opening a menu will slow it down).

Quicktime: If you are using Quicktime as your means of hearing or sending the chords, and you hold the option key down when starting to play, Quicktime will use its own inbuilt functions to play the sequence. The timing will be good but the chart won't show the progress.

If 'Metronome' is checked in the Options Menu you will hear a metronome click. If you are using OMS this is sent out on channel 10, so ensure that your multitimbral module has a drum set selected for that channel (it usually is by default). I will give more options for the metronome in the next version, but for now if it is too loud, adjust the volume for channel 10 in your sound module.

7. Tempo The tempo can be changed during play back from, effective from the next chord reached. Click and drag up or down to change, or double-click. (1-500, default 120).

TIP: The optimum layout sequence is:
Get in all the music roughly. Then change any bars per line. Then move any actual barlines. Then nudge any chords. Then add any text.

MORE ABOUT TIME SIGNATURES
Chord Studio charts don't take into account the time signature denominator in most functions. That's to say a beat is a beat, and 6/4 and 6/8 are treated the same. If you paste two beats from a 4/4 bar into a 6/8 bar you will only end up with an 8/8 bar. An exception is when you play a chart, or export one as a MIDI file, when you will hear the faster rate during bars with shorter denominators.

It is hoped that users will create and share their own charts. I have included a few using the changes from a few jazz standards and some of my favourite jazz voicings. Please email your own creations to me and if I like them I'll make them available to all on these pages! It would be great to build a comprehensive library of charts.